Hobby website

Tasks:
1. Duplicate your a3 folder and create a new a4 folder
2. Creating a graphical nav bar using Photoshop
3. Adding the sliced nav bar to the index page
4. Add navigation to footer
5. Add a rollover effect to nav bar using Behaviors in DW
6. Duplicating index.html
7. Customize thumb gallery on gallery.html
8. Creating a new example of a CSS class
9. Creating a tag style for an html tag
10. Create a Pseudo class in order to style our hyperlink states
11. Add sample content to each page
12. Upload all pages using Dreamweaver’s built in FTP
13. Extra Credit creating a form on contact.html
Assignment overview:

This week we will be creating a hobby website based on the template we created in A3. You will duplicate your A3 folder and then rename A4. We will use Dreamweaver and Photoshop in order to complete this assignment. We will be adding a sliced nav bar created in Photoshop as well as creating several new pages. The nav bar will have a rollover effect which we will add using Behaviors in DW. You do not have to follow these steps exactly as long as you meet the minimum assignment requirements.
**Requirements:**

- Duplicate your A3 folder and then rename this new folder as A4.
- Add a “sliced” main graphical navigation to your index page
- Main nav should provide an example of a graphics nav bar with a rollover effect
  
  *(create nav bar graphics in Photoshop or similar program)*
- The rollover effect changes the appearance of part of the graphic when someone
  mouse’s over a nav bars button/option
  
  *(create the roll-over graphic in Photoshop)*
- Add rollover effect in DW using Behaviors
  
  *(adds Javascript to image/button)*
- You must use the exact same main nav on all your pages, exact same location,
  same size etc.
- Add hyperlink navigation to footer
- Create a gallery and contact page based on the index page
- Add a thumb gallery on gallery.html
- Create a new example of a CSS class
- Creating a tag style for an html tag
- Create a Pseudo class
- Add sample content to each page
- Add contact information on contact.html
- Upload to your web host
- Add link on cmp.html to a4. A4 links to index.html within a4 folder
- Extra credit add a contact form on contact.html
Step 1 – Duplicate your a3 folder

Make sure your a3 template and all its components were saved into an a3 folder. You were required to create only one webpage for a3, index.html

- A4 will be based on the webpage template you created in a3
- We want to first duplicate your A3 folder
- Make sure there no webpages currently open in DW
- Within the Files panel duplicate your A3 folder by selecting the A3 folder and then right mouse+click (pc) or control+click(mac) and select the Edit>Duplicate option.
- Within the Files panel select the a3 copy folder and rename as a4. Click inside the name of the folder in order to highlight the name allowing it to be renamed.
- Expand the new a4 folder and verify there is an index page inside the folder
- If you happened to name the webpage file something other than index.html make sure to rename it index.html at this time.
- Open index.html making sure you are working within the a4 folder
- The original a3 files should remain in the a3 folder and we will not be modifying that assignment.
- In the next step we will be creating a graphical style nav bar to add to the index.html page within our a4 folder

Step 2 – Creating a graphical nav bar using Photoshop

Next, we will create a sliced graphical style navigation bar (aka nav bar). We will actually use the same nav bar on each page we will be creating for a4. In order to standardize the nav we will put in the exact same location on all your pages for a4. The main graphical nav must provide an example of a sliced graphic nav bar with a rollover effect. In the example below we will first create the nav bar graphic in Photoshop, slice, and export with a transparency option. There are several ways to complete this step and the way described below is just one way of creating a sliced graphical nav bar.

- Open up Photoshop.
- Please note the following Instructions are likely slightly dif in the latest version of Photoshop CC. If you are having problems following these steps please email me.
• In Photoshop create a new document sized approximately **640 pixels wide by 70 pixels high**. Resolution approx. **72 pixels/inch**. Color mode **RGB 24 bit**. Make sure to select the **background transparent** option.
• Feel free to adjust the above size of your Photoshop document
• Once your document opens you should see a grey checkerboard showing representing the transparent areas.
• Transparent means there will be no background color showing.
• The following is a guideline feel free to design your graphical nav bar however you want as long as you create at least three buttons and have transparency around the nav bar.
• Click on the **Rectangle (Shape)** tool located on the tool bar.
• Click on the **set foreground** color swatch and select the desired color for your nav bar.
• Look at the top of the screen and select the **Rounded Rectangle** option if desired.
• Recommended settings:
  - Radius: **10px**, Mode: **Normal**, Opacity: **100%** and select the **Anti-alias** option
• Click on your document window and while holding down the mouse button drag down and to the right, let go of button, drawing a rectangle.
• If you want to undo the shape drawn click on **command+Z** (mac) or **cntrl+Z** (pc).
• Draw the shape so that it fits inside your document window space. You should still see the transparent background around the shape.
• Optional: Add a stroke to your nav bar shape **Edit>stroke**, pick a width and different color.
• Next, click and hold down the mouse button on the **Text** tool.
• Make sure it is set to the **Horizontal type** option.
• Select desired font, size, etc on the top tool bar.
• Click on the document and type the name for our first button, main.
• Select the **Move Tool** (V) on the tool bar.
• Move text to desired location.
• Repeat steps and add text for two more buttons, gallery and contact.
• For example, click on **Text tool** to type a name like gallery and then use **Move Tool** to desired position, etc.

• Make sure you have text for your three buttons, for example main, gallery, contact.

• Next, select the **Slice Tool** (K) we will use to define the space of our three buttons.

• Use the Slice tool to draw a box around the area you want to represent the main button.

• Required: Very important note!!!! In the latest version of Photoshop CC and with HTML5 make sure that the slice goes all the way from the top to the bottom of the graphical nav bar. Meaning don’t draw a box inside the graphic the buttons should go from the very bottom of the Photoshop graphic to the very top of this graphic.

• Click and while holding down the mouse button down drag down and to the right and then let go of the mouse button. You should end up with a box with the text main appearing inside.

• If you don’t like the box that was drawn you can adjust the sides by clicking on and dragging the edges of the slice or switching to the slice select tool to adjust.

• The slice we are creating is meant to represent our main button.

• Once you have drawn a box/slice around main draw a similar box around gallery. Repeat again for the last button contact.

• After drawing our 3 slices adjust each slice so that all three slices have the same height and so that the bottoms of each slice line up similarly.

• Make sure the three slices go all the way to the top and to the bottom of the Photoshop Graphic.

• Zoom in/out if necessary **command+** (mac) or **cntrl+** (pc) / **command-** (mac) or **cntrl-** (pc) (**zooms back out**).

• Switch to the **Slice Select Tool** located on the tool bar shared with the Slice tool. Click and hold down the mouse button and then select the Slice Select option.

• With the Slice Select Tool double click inside of the slice for the main button.

• Type values for the following
Name: mainUp, URL: index.html, Alt Tag: main button

• Repeat step for the gallery slice, double click inside of the slice for the gallery button.
  
  Name: galleryUp, URL: gallery.html, Alt Tag: gallery button

• Repeat step for the contact slice, click inside of the slice for the contact button.
  
  Name: contactUp, URL: contact.html, Alt Tag: contact button

• These are the only 3 slices we need to edit, representing the 3 buttons for our nav bar, the areas/slices around the nav bar are also slices but do not need to renamed.

• Next, we are ready to do a Save for Web.

• Click on File>Save for Web…

• Click on command+A (mac) or cntrl+A (pc) in order to select all.

• Select the PNG-24 option and make sure the transparency option is selected or checked.

• Click on Save.

• Very important must Save inside the root of your a4 folder (meaning don’t create an additional folder inside a4).

  File name: navbar.html

  Save as type: HTML and Images Only (.html)

  Settings: Default Settings

  Slices: All Slices

• Click on Save.

• Photoshop just created an html page with your nav bar graphic sliced (cut up) and put inside a table on this page. Note: Photoshop automatically created an images folder inside your a4 folder.

• File>Save and save the .psd photoshop document file. We are not done in Photoshop so do not close.

• Next, we are going to create a roll over appearance for just our 3 button slices

• Switch to the Slice Select Tool located on the tool bar shared with the Slice tool.

• Click and hold down the mouse button and select the Slice Select option.

• With the Slice Select Tool double click inside of the slice for the main button
• Change only the values for the following
  
  Name: mainRoll

• Repeat step for the gallery slice, double click inside of the slice for the gallery button
  
  Name: galleryRoll

• Repeat step for the contact slice, double click inside of the slice for the contact button
  
  Name: contactRoll

• Next, we will make a rollover appearance for our 3 buttons.

• Make sure the layers panel is showing, to open Window>Layers.

• First we want to duplicate the 3 text layers.

• While holding the Alt key select the Text layer called main and drag layer directly above the layer and then let go of the mouse button.

• You should see a new layer appear, it should say main copy (or whatever the text reads and then copy).

• Select the main copy layer.

• Double click inside the text that says main copy and rename to mainRoll.

• Turn off the original main layer by clicking on the eye on left side of layer for the layer called main.

• Repeat steps for the other two layers, gallery and contact.

• While holding the Alt key select the Text layer for gallery and drag layer directly above the layer.

• Select the gallery copy layer.

• Double click inside the text that says gallery copy and rename to galleryRoll.

• Turn off the original gallery layer by clicking on the eye.

• While holding the Alt key select the Text layer for contact and drag layer.

• Select the contact copy layer.

• Double click inside the text that says contact copy and rename to contactRoll.

• Turn off the original contact layer by clicking on the eye.

• Double click on the mainRoll layer and the Layer Style window will open.
• Modify text to have a new appearance, for example you might select the *Outer Glow* option.
• Once selected pick a *glow color, adjust spread and size.*
• Click *Ok* to close Layer Style window.
• On the mainRoll layer you will notice an *fx* icon appearing indicating there is a layer effect.
• Select the mainRoll layer and while holding the Alt key down, drag layer onto galleryRoll layer.
• Repeat step, select either layer with an effect, hold down alt key and drag onto contactRoll layer.
• You should now have 3 new looking buttons, at least, the text has changed appearance to have some kind of effect.
• Next we are ready to Save for web.
• Click on *File>Save for Web…*
• Using the *Slice Select tool*, select only the three slices representing the three buttons with text. Hold down the shift key while selecting. You should see only the main, gallery, contact slices selected.
• Select the *PNG-24* option and make sure the transparency option is still selected.
• Click on *Save*.
• Save inside the images folder within your a3 folder.
  
  File name: *not necessary to fill out, ignore*
  
  Save as type: *Images Only (.png)*
  
  Settings: *Default Settings.*
  
  Slices: *Selected Slices*
• Click on *Save*.
• Important Note: It should not give you any warning about replacing existing images since we are only saving selected slices and they have new names like galleryRoll.
• Photoshop just exported and created only the three images representing the three roll over images we will use for our nav bar.
• File>Save and save the .psd photoshop document file.
• We are done in Photoshop so you can exit.

Step 3 – Adding the sliced nav bar to the index page
Next, we will be adding the nav bar we created in Photoshop to our first page of a4 index.html. When we exported our nav bar in Photoshop we created an html page called navbar.html with images. Photoshop puts our sliced nav bar into an html table. We will open navbar.html and then copy the table and nav bar code into our index page.

• Return to Dreamweaver.
• Next we want to open the html page Photoshop created for us in the last step.
• Click on File>Open and navigate to the a4 folder and select nav bar.html or whatever you named the file. Do not open index.html since that page is not the Photoshop page and is most likely already open.
• Note: if you did not save your nav bar page into the A4 folder you will have problems in this step. If necessary move the nav bar page and image folder into the A4 folder before continuing.
• Once you are able to open nav bar.html you should see your nav bar graphic appearing on a white webpage.
• Click on edge of graphic in order to select the table containing the nav bar. You want to select the outer edge of the table our graphic is in.
• Be careful not to move table or to adjust the sides of the table.
• Once it is selected click on Code view option.
• You should see the entire table selected (highlighted from <table> to </table>).
• While selected copy, cmd+c (mac) or ctrl+c (pc).
• Switch to the index.html page, it should already be open, click on the index.html tab to display the page.
• Click on the Code view option.
• Place cursor inside the nav tags <nav></nav> and if nec press return to better see where the cursor is now displayed.
• Remember in A3 we were supposed to have a sample navigation inside our nav tags, if you didn’t originally have a sample nav then don’t worry about deleting anything. But we want to remove any content that is in the nav tags.
• Select the original sample nav located in our <nav> tags
• Highlight and delete the following code.

```html
<table width="400" cellpadding="10" align="center">
  <tr>
    <td>
      <a href="index.html">Main</a>
    </td>
    <td>
      <a href="#">future page</a>
    </td>
    <td>
      <a href="#">future page</a>
    </td>
  </tr>
</table>
```

• Your nav tags should now be empty

```html
<nav>
</nav>
```

• We will be replacing the deleted nav with the graphical nav we copied.
• Place the cursor inside the nav tags and paste table with the graphical nav,
  `cmd+V (mac) or cntrl+V (pc)`.
• You should now see the table code displayed in the nav tags of the index page
• Switch to Design view and make sure you can see your nav bar.
• Troubleshooting: If for some reason the images do not show then you may need to save index.html or you will need to move the images folder being used by the nav bar inside the A4 folder where index is supposed to be saved. Both index.html and the sliced images folder must be in your A4 folder.
• If your nav bar shows then `File>Save`
Step 4 – Add navigation to footer

In this step we are going to move the sample navigation that was inside the nav tags and move inside the footer tags.

• Next we want to add a sample nav to the footer.
• Copy and paste the following inside the <footer> tags.
• Make sure to modify the hyperlinks to match the names and pages you will be using for your hobby website.

```html
<a href="index.html">Home</a>
<a href="gallery.html">Gallery</a>
<a href="contact.html">Contact</a>
```

• Optional add a table with one row and 3 cells to hold these hyperlinks. Continue to the next step where we will add our rollover effect to our nav bar.

Step 5 – Add a rollover effect to nav bar using Behaviors in DW

The rollover effect will allow us to change the appearance of our nav bars buttons when someone mouse’s over a particular button. We previously created the roll-over graphics in Photoshop. In this step we will apply the effect in DW using Behaviors. Behaviors adds Javascript code inside of the html code.

• In DW select the main button (image).
• On the Properties window add a name for this graphic, type main in the text box on the far left directly under where it says Image. This step is optional in case you are having trouble locating. Repeat steps, select gallery button then add the name gallery. Select contact button then add the name contact.
• Select main button again.
• Open the Behaviors panel, Window>Behaviors.
• On the behaviors panel click on the + plus sign and select the Swap Image option.
• Under Set source to: click on the Browse button and select the mainRoll image located inside the A4 folder inside the images folder, click Ok.
• Make sure to keep the Preload and Restore options selected and then click Ok.
• Repeat steps for both the gallery and contact buttons. Select gallery button, click on + *(Behaviors panel)*, select Swap Image, select galleryRoll, etc. Select contact button click on +, select Swap Image, select contactRoll, etc.

• Save index.html, *File>Save.*

• Test nav bar rollover *File>Preview in Browser>pick a browser.*

• When browser opens, mouse over each button, you should see the rollover effect appear.

• Verify there is a working hyperlink associated with each button. Clicking on main should take you to index.html the current page, clicking on contact and gallery would take you to their respective pages. Those pages don’t exist yet but we will create in the next step.

• *Troubleshooting:* If you are having problems getting the rollover to appear on the nav bar select the slice or button graphic with no rollover showing and look for the Swap Image behavior listed in the Behaviors panel. Double click on Swap Image to edit, or remove by clicking on the – minus sign. If you remove make sure to also remove the swap image restore and then try adding back using the original steps. There are only rollovers for the main, gallery and contact graphics.

• You must have a working nav bar and with hyperlinks before continuing.

• Save before continuing to the next step, *File>Save.*

**Step 6 – Duplicating index.html**

In this step we will be duplicating our index.html page and create the two other needed pages gallery.html and contact.html. Make sure you have successfully added the graphical nav bar to the index page and the rollover effect is working correctly before continuing on with this step.

• Make sure the index.html page is still open in DW.

• *File>Save*

• Next we will duplicate the index page by doing a save as

• *File>Save As*, gallery.html and make sure to save inside the a4 folder.

• Repeat step for contact page, *File>Save As*, contact.html

• You should notice all three pages now open in DW.
• Make sure to add unique descriptive titles to each page
• In DW there is a title field above the design view area for the man area of the page
• Titles can also be seen in the <title></title> tags within the head
• **File>Save All**
• Test website **File>Preview in Browser>pick a browser**
• Make sure the main nav works on all pages and does not shift location from page to page.

**Step 7 – Customize thumb gallery on gallery.html**

In this step we will be modifying our thumbnail gallery on gallery.html. You are going to display a minimum of 6 images sized 640x480 or larger. Remember these images should relate to your hobby. If you don’t have images related to your hobby go download some samples images to use [http://images.google.com](http://images.google.com) or [http://images.bing.com](http://images.bing.com).

• You should already have some example images from when we created our template in a3.
• Open up gallery.html
• Your images should relate to the topic of the website which is about your chosen hobby.
• If necessary delete the existing thumb images and go through the following steps to create images for your hobby website.
• gallery.html must contain at least 6 thumbnail images that will link to larger images.
• Thumbnails will link to larger pictures in a new window using _blank or javascript/behaviors
• Recommended that you use an image batch automation in a graphics program to quickly create the two image sizes
• Gather your 6 desired images, should be sized 640x480 or larger
• We will need six images to use for our gallery. The images should relate to the content of your website, your hobby or interest.
• Place your six images inside the a4 folder. Put inside the images folder and within a folder called original_images.
• Note: If you have an existing folder named original_images open and decide which images to keep and which to delete
• Images will need to be sized 640x480pixels or larger.
• We will use a batch automation within Photoshop in order to automate the creation of both the larger version and our thumbnails.
• Open up Photoshop and then click File>Scripts>Image Processor
• Click on Select Folder and select the original_images folder
• Next for the save option Select Folder option and click on Make a New Folder then type a name like 640.
• For file type select Save as JPEG quality 5 and select the Resize to Fit option and add W:640px H:640px. (this represents the max height and/or width for the new picture)
• Click on Run.
• Photoshop will run a batch process creating 6 new images sized max 640x640, images will be put into a folder called JPEG inside the 640 folder inside the 640 folder.
• Next we want to run the step again in order to create the thumbnails.
• Click File>Scripts>Image Processor
• Click on Select Folder and select the gallery_images folder.
• Next for the save option Select Folder option and click on Make a New Folder then type a name like thumbs.
• For file type select Save as JPEG quality 5 and select the Resize to Fit option and add W:110px H:110px
• Click on Run.
• Exit Photoshop.
• Navigate to the original_images within your a3 folder and verify there are two new folders. Verify that the images were resized approximately to sizes 640x480 and 110x80, sizes will not match exactly because different images have different aspect ratios.
Photoshop likes to put the images inside a JPEG folder. Recommended you move images directly into the 640 folder and the thumb folder. If possible move these two folders into your existing images folder located inside a4. Make sure to keep the two separate folders called 640 and thumb since the files inside these are named exactly the same or rename images to desired new name and place in your existing images folder.

Return to Dreamweaver and edit gallery.html

Gallery images should be put somewhere inside the article tags

Decide where you want your gallery to appear on the page and make sure to add a table to hold the images in our gallery Insert>Table

Insert>Image and select the first thumbnail inside your thumb images folder within the a4/orig_images/thumbs/ or a4/images/thumbs or wherever you decided to save them.

After inserting, select thumb on the page, make sure you are in the Design view. Once the thumb is selected on the Properties window find Link and click on the folder icon (Browse for File).

Select the larger version of this image within the 640 folder, orig_images/640/ or wherever you decided to save them.

The filenames for the thumb and 640 will probably be the same but they are probably stored in different folders, take care to pick the correct version/size.

Recommended, under Target select the _blank option.

Adding a Target _blank is not required, however, it is recommended since this will open a new blank window when someone clicks on the thumb image.

Repeat steps for the remaining images, you are required to have at least six thumbs which link to larger versions.

If you do not see the Target option, located on the 3rd row down, then expand the Properties window by clicking on the down triangle on the far right side of window.

Required: apply your existing .thumbBorder class to all your thumb images

Select a thumb then under Properties look for class and select the thumbBorder class, repeat steps for each thumb image.
Step 9 – Creating a new example of a CSS class

Next, we will create another example of a CSS class. A class is also known as a custom style that we define in our CSS that allows you to apply the custom style as many times on a particular page or different webpages. Create some type of custom style and then apply it to at least one item or selection in your a4 website. We originally created our first class or custom style in a3 and created a class called .thumbBorder

• The following is just an example and you can create any type of class (custom style) and apply it to some content in one of your 3 webpages. This class must be different than the thumbBorder we applied to our thumb images in the last step
• Make sure CSS Styles/CSS Designer window is open, if nec. open via Window> CSS Styles/CSS Designer
• In DW CC click on new rule + under the Selectors section
• Type the name for this class style like .yellowBg
  (must include the period at beg of name in order for it to be a class)
  i. Note: In older versions of DW, in order to add a class click on the New CSS Rule button, icon with a +.
• Type or select the following:
  Selector Type:  Class
  Selector Name:  yellowBg
    (type anyname you want but with no spacing)
  Rule Definition: yourfilename.css
    (this will display what your ext css is named)
  Click Ok

• Select Background under Category.
• Modify the background-color:
Pick a yellow color

Click on **Ok**.

Next we want to apply the class to a selection somewhere on your pages.

Select the desired selection, then on the Properties window for **Class** select the name of your class like yellowBG.

Anytime you want to go back and edit the class, you can double click on the classname listed under all rules or go to the css code view.

Save and view **f12**.

Just a reminder you can create any type of styling example for a .class and the above was meant just as an example of one way to style a class.

In the next step we will create a css tag style

**Step 10 – Creating a tag style for an html tag**

Next, we will create an example of a “tag style”. A tag style is also known as a HTML style that we define in our CSS that allows you to style any HTML tag a specific desired way. Creating a tag style makes every use of that html tag styled a specific way based on what we define in the style. Think of “tag styles” as a style for a particular HTML tag.

- In DW CC click on new rule + under the Selectors section
- Type the name of the tag you wish to style (no period at beg of name!)

Type or select the following:

- **Selector Type:** tag
- **Selector Name:** h1
  
  *(select the desired html tag)*

- **Rule Definition:** yourfilename.css
  
  *(this will display what your ext css is named)*

  Click **Ok**

- Select a Category.
- Modify properties like Font size and possible font
- Click on **Ok**.
• If order for the style you just created to be seen you will need to have an example of the html tag somewhere in one of your pages
• If nec add an example of the tag like the h1 tag used in the example
• Anytime you want to go back and edit the style, you can double click on the tag listed under all rules or go to the css code view
• Save and view f12.
• In the next step we will create a css pseudo class style

**Step 11 – Create a Pseudo class in order to style our hyperlink states**

• Next, we will add what is called a “pseudo class” to style all hyperlinks and be able to style the various states of a hyperlink. Remember we added hyperlinks to the footer in an earlier step.
• Add a pseudo class (styling based on dif states) to style hyperlinks on all pages. The states are shown below link, visited, hover, active (appearance while the mouse button is pressed down)
• In DW you can view stylesheet code by clicking on anyname.css (or whatever you css is name) css source option located next to source code at top of page near tab index.html.
• Copy and paste the code shown on the next page into your external CSS.
• Modify color as desired, #0CF represents the hex color value. Hex color is best way to work with colors on computers when working with graphics and web pages etc.

```css
a:link {
    color: #0CF;
}
a:visited {
    color: #006;
}
a:hover {
    color: #03F;
}
a:active {
    color: #9FF;
}
```
• Click on source code to close the CSS code view.
• Once we have added to our css file you can easily modify these colors using the CSS Designer panel
• Click on the desired state and select the color you want for that state
• These are the different states of a hyperlink, A:link is a standard hyperlink, a:visited is the color you want the hyperlink to be once it has been visited, a:hover is the color you want the hyperlink to be when you hover over it, and a:active is the color you want to be when someone clicks on it and holds the mouse button down
• **File>Save All**
• In the next step we will make sure there is content on each page as we finish up the assignment

**Step 12 – Add sample content to each page**
• Next we want to verify that there is enough content on each of our pages in a4
• Add two additional paragraphs of sample content to our index page.
• Write at least 3 sentences in each of these new paragraphs.
• Required: Your index page has to have a total of 4 paragraphs
• Modify content on gallery and contact so that there is no duplication of content on those pages. We want each page to have unique content. Required, gallery and content pages should have a paragraph explaining what type of content is on those pages so the viewer has an idea what that particular page is about. Remember all the content on these three pages needs to be about your hobby do not use placeholder text or lorem ipsum text.

**Step 13 – Upload all pages using Dreamweaver’s built in FTP**
• Make sure you have added links on your cmp.html *(course management page)* to A4, linking to the *index.html* page within the A4 folder.
• Save all your pages, **File> Save All**
• Upload the entire A4 folder
• Make sure to send an email with your assignment URL to the Instructor when you have uploaded and are ready to be graded.

Extra credit  Step 14 – Creating a form on contact.html
The following step explains how to create a HTML form and add it to conact.html. Forms allow you to add interactivity to your website. Users can fill out a form and then submit the data. Forms do require some type of script to process the form data. The most popular type of script that is used for form processing is CGI or PHP. Most free web hosts do not offer any scripts to use for form processing; however paid web hosting will offer scripts. If you are not paying for web hosting you can use a free service like this http://allforms.mailjol.net/free.php in order to process our form data.

• The form should only show on the contact page.
• Make sure you are on the contact.html page
• Customize your form to your liking and make sure the questions are relevant to your hobby page
• Provide examples of the following form field elements in your form:
  <input type="text">
  <textarea>
  <input type="radio"> or <input type="checkbox">
  (in DW use radio group or check box group options)
  <select><option>

• The following explains how to create a basic form and how to add a fully functioning form that allows users to fill out various form fields and also has a submit button. Follow the steps explain how to create a form from scratch.
• Your form must be fully functioning including allowing users to successfully submit form data by referencing a form script. The form needs to reference a script in its action in order for form to properly submit the form data.
• Instructions begin on the next page.
How to create an HTML form in DW.

- Select where you want the form to appear, position cursor where you want your form to appear.
- On the Insert panel, click on the Forms tab. Click on the Form button.
- In Design view, forms are indicated by a dotted red outline. If you don’t see this outline, select View> Visual Aids> Invisible Elements.
- Within the Properties window notice the Method pop-up menu, it specifies the method to transmit the form data to the server.
- Typically, the default value is the GET method. GET Appends the value to the URL requesting the page. POST Embeds the form data in the HTTP request. You can use either method.
- When inserting form items remember to set the properties of each of the objects.
- Enter a name for the object in the Property inspector or in the Input window.
- Every text field, hidden field, check box, and list/menu object must have a unique name that identifies the object in the form.
- Form object names cannot contain spaces or special characters. You can use any combination of alphanumeric characters and an underscore (_).
- The label you assign to the object is the variable name that stores the value (the entered data) of the field. This is the value sent to the server for processing. For our example this value will display in the email before the users input data.
- **Note:** All radio buttons in a group must have the same name.
- To label the text field, check box, or radio button object on the page, click beside the object and type the label.
- Adjust the layout of the form using line breaks, paragraph breaks, preformatted text, or tables to format your forms.
- You cannot insert a form in another form (that is, you cannot overlap tags), but you can include more than one form in a page.
- When designing forms, remember to label the form fields with descriptive text to let users know what they’re responding to—for example, “Type your name” to request name information.
• Use tables to provide structure for form objects and field labels. When using tables in forms make sure all the table tags are included between the form tags.
• Try adding some form items, see the line below
• Click on the Text Field button
  • ID: first_name
  • Label: First Name:
  • Under Style:, select the No label tag option
• Click Ok. Press Return to add a new paragraph or shift+return to add a line break
• Repeat steps adding various other form elements
• You must also add a submit button to your form
• Click on the code view to view your form code
• Locate the opening form tag
  <form id="form1" name="form1" method="post" action="">
  • The action="" represents where you will need to add the url of your form script
  • Use a free service like http://allforms.mailjol.net/free.php unless you are paying for web hosting, then contact your web host for their form script.
  • Do not use a pre-created form found at this website! Only use the script in the custom made form you create in DW
  • Using the above service will require you to register and then set up a sample form and then copy the action URL.
  • You will need to find out the URL for your form script and add it to your opening form tag in the actions parameter. The following is an example yours will look different.
  <form method="post" action="http://allforms.mailjol.net/hhkdsa.php" >
  • Make sure you have used your own unique code in the action
  • Test form by saving page and previewing in browser
  • Fill out form and press submit, check the email you used when registering to see if data was sent successfully.
  • Required, form should only appear on the contact.html page!